Author Topic: Trying to Debug Google Image Sharing Glitch  (Read 1274 times)

Offline kothmann

  • Viscount
  • ****
  • Posts: 806
  • Merit: 92
  • Oh! That’s interesting...
    • View Profile
Trying to Debug Google Image Sharing Glitch
« on: January 19, 2024, 09:09:34 AM »
I am posting this partly as an example to share with google support but also in case anyone else has any insight.

Since I started posting here almost 3 years ago, I have always embedded images that are stored on google drive, but all of those images are now not showing up!   :-[

As an example, between the two horizontal lines below, there is an "img" tag linking to a google drive image, but it won't show up any more. (Please reply if you see the image!)







The google drive share permissions are fine, because you can just click on the link that is inside the "img" tag and it works
https://drive.google.com/uc?export=view&id=1C_t5SU7J1sfdEconO5BcWz0LGj0_1YiL

For comparison, here is what the image looks like when shared from my new Flickr account.

https://live.staticflickr.com/65535/53466844492_95a0a232cd_z.jpg

Linkback: https://www.carcassonnecentral.com/community/index.php?topic=6573.0

Offline SailingMeeple

  • Freeman
  • ****
  • Posts: 54
  • Merit: 7
  • All Meeples on Deck!
    • View Profile
Re: Trying to Debug Google Image Sharing Glitch
« Reply #1 on: January 19, 2024, 10:08:23 AM »
Hi kothmann,

Interesting: when I look at your post on my laptop, I only see the image on Flickr.
When I look on the Tapatalk app, I do see the image from Google Drive and (eventually) also the image on Flickr. (That one took a bit longer to load on the app but it got there with a bit of patience.)

No clue why it wouldn't show using one device and does show on another...

Offline kothmann

  • Viscount
  • ****
  • Posts: 806
  • Merit: 92
  • Oh! That’s interesting...
    • View Profile
Re: Trying to Debug Google Image Sharing Glitch
« Reply #2 on: January 19, 2024, 10:26:26 AM »
That's interesting and helpful.  Thanks.  Just to confirm: on Tapatalk, there is an image between the horizontal lines (from the "hr" tag)?

I have had this google drive failure intermittently before, typically where some images in a post will load and others won't.  It would always resolve within a day or two.  But now it seems to be all images fail all the time on all of my devices.    :(

Offline SailingMeeple

  • Freeman
  • ****
  • Posts: 54
  • Merit: 7
  • All Meeples on Deck!
    • View Profile
Re: Trying to Debug Google Image Sharing Glitch
« Reply #3 on: January 19, 2024, 10:35:11 AM »
Yes, exactly: on Tapatalk I see both the images (between the horizontal lines and the one at the end of the post).
On my laptop, I only see the one at the end of the post.
Hope it helps!  :yellow-meeple:

Offline Snearone

  • Duke
  • *
  • Posts: 231
  • Merit: 126
    • View Profile
Re: Trying to Debug Google Image Sharing Glitch
« Reply #4 on: January 19, 2024, 10:54:57 AM »
Hey, I saw your previous message on this subject in one of the topics.
Personally, I've never had a problem with your photos, I've always liked that you insert them in full size without scaling.
I checked then on three browsers on PC (firefox, opera, chrome) on my phone on two (firefox, chrome) and have not encountered any problems both on the site and via tapatalk, via home internet and mobile.
In addition I also recently looked at CarcC from another country and different PC, also no problems with your photos.
« Last Edit: January 19, 2024, 10:57:14 AM by Snearone »
Completed: Robber's Son | Gambler's Luck | Vistas Revisited | First Wells | The Flying Machines 2
WIP: The Occult Tower | Binding Deed | Wandering Preachers | City Gates Rebuilt | New King's Orders

Offline Scott

  • Administrator
  • Viscount Chevalier
  • *
  • *
  • Posts: 3185
  • Merit: 114
    • View Profile
    • CarcassonneCentral
Re: Trying to Debug Google Image Sharing Glitch
« Reply #5 on: January 19, 2024, 11:32:26 AM »
I can also see the photos on Tapatalk.


Sent from my iPhone using Tapatalk

Offline kothmann

  • Viscount
  • ****
  • Posts: 806
  • Merit: 92
  • Oh! That’s interesting...
    • View Profile
Re: Trying to Debug Google Image Sharing Glitch
« Reply #6 on: January 19, 2024, 12:00:00 PM »

I checked then on three browsers on PC (firefox, opera, chrome) on my phone on two (firefox, chrome) and have not encountered any problems both on the site and via tapatalk, via home internet and mobile.
In addition I also recently looked at CarcC from another country and different PC, also no problems with your photos.
Wow, thanks!  Confusing…

I can also see the photos on Tapatalk.
Thanks

Offline Snearone

  • Duke
  • *
  • Posts: 231
  • Merit: 126
    • View Profile
Re: Trying to Debug Google Image Sharing Glitch
« Reply #7 on: January 20, 2024, 05:13:19 AM »

Offline kothmann

  • Viscount
  • ****
  • Posts: 806
  • Merit: 92
  • Oh! That’s interesting...
    • View Profile
Re: Trying to Debug Google Image Sharing Glitch
« Reply #8 on: January 20, 2024, 07:29:28 AM »
Thanks @Snearone for the very informative links.

Ugh.  I’m hoping they can fix it somehow but not optimistic.


Offline Decar

  • Owner
  • Chatelain Grand Officier
  • *
  • *
  • Posts: 6719
  • Merit: 317
  • Shut up and take my money!
    • View Profile
    • tehill.net
Re: Trying to Debug Google Image Sharing Glitch
« Reply #9 on: January 20, 2024, 10:07:46 AM »
Probably a security thing to stop gdrive / photos being used to host images on sites.

@kothmann If it helps, I can set you up with an SFTP to upload images to that are easy to embed.

Offline kothmann

  • Viscount
  • ****
  • Posts: 806
  • Merit: 92
  • Oh! That’s interesting...
    • View Profile
Re: Trying to Debug Google Image Sharing Glitch
« Reply #10 on: February 12, 2024, 11:23:38 AM »
Well, a month on and there seems to be no fix from Google, so I think it has to be a new security "feature".

I discovered a pretty simple edit that seems to work.  Just use this format for the img tag:
Code: [Select]
[img]https://drive.google.com/thumbnail?id=<insert google file id here>&sz=w350[/img]
The "w350" specifies the width.

I updated my first forum post -- perhaps a few others can confirm that they see the image at the top of this post:
https://www.carcassonnecentral.com/community/index.php?topic=4962.msg76193#msg76193

I may try to work my way through all ~800 of my posts and update the image links... good memories  :)

Thanks everyone for your help.

Offline SailingMeeple

  • Freeman
  • ****
  • Posts: 54
  • Merit: 7
  • All Meeples on Deck!
    • View Profile
Re: Trying to Debug Google Image Sharing Glitch
« Reply #11 on: February 12, 2024, 12:41:31 PM »
I see the image! :D Update: I checked it on both the app on my phone and on my laptop. I see the image in both! Woohoo!
Glad you found a way around the new security 'feature'  ::) .
« Last Edit: February 12, 2024, 12:43:13 PM by SailingMeeple »


Share via delicious Share via digg Share via facebook Share via furl Share via linkedin Share via myspace Share via reddit Share via stumble Share via technorati Share via twitter

  Subject / Started by Replies / Views Last post
xx
Spy or Die Trying

Started by Scott

3 Replies
8547 Views
Last post April 22, 2013, 05:41:44 PM
by Scott
thumbup
Kill Yourself or Die Trying: Zombicide (Grindhouse Scenario)

Started by danisthirty

7 Replies
5593 Views
Last post April 19, 2016, 08:05:02 AM
by dirk2112
xx
Cinque Terre Board Game (a little image heavy)

Started by franks

4 Replies
4037 Views
Last post July 05, 2016, 09:42:59 PM
by franks
xx
Anyone have a quality image of Corn Circles I?

Started by SirReel

2 Replies
10102 Views
Last post November 09, 2013, 02:45:11 PM
by SirReel
xx
Fresco Big Box (image heavy)

Started by franks

3 Replies
2914 Views
Last post October 08, 2017, 08:59:40 AM
by Decar