Author Topic: "Connection Lost" on local game  (Read 2219 times)

Offline farin

  • Duke
  • *
  • Posts: 233
  • Merit: 41
  • JCloisterZone maintainer
    • View Profile
Re: "Connection Lost" on local game
« Reply #15 on: December 24, 2017, 03:11:19 PM »
rfielder - please try 4.1.0. and let me know

At least it uses latest websocket library + fixes some important issues related to networking on my side
Eg reconnecting really means reconnection and not crash ;-)

I still wonder why you have troubles on local network, but if remains we can continue with investigation.

Offline rfielder

  • Marquis
  • ***
  • Posts: 472
  • Merit: 10
  • Carcassonne Beginner
    • View Profile
    • Cool Country Nights
Re: "Connection Lost" on local game
« Reply #16 on: December 25, 2017, 09:12:38 AM »
rfielder - please try 4.1.0. and let me know
farin - thanks!

One game played, no issues.  Far from conclusive, but a good start.

Will let you know in  a day or two how it goes.

Merry Christmas!
Robert Fielder
Brampton, Ontario, Canada  EST

Offline rfielder

  • Marquis
  • ***
  • Posts: 472
  • Merit: 10
  • Carcassonne Beginner
    • View Profile
    • Cool Country Nights
Re: "Connection Lost" on local game
« Reply #17 on: December 26, 2017, 04:13:59 AM »
farin - JCZ 4.1 has been good for a few games.

Last game ended up hung, kind of.  Screen capture is attached.

I am playing green.  The arrow shows that it is my move.  However, there are no possible locations outlined.

There is a "1" showing, right side of the board, but it is showing on an unused space.

I can more the board around, and interact with the menus, but I can not place the tile, or otherwise play the game.

Only way out was to Leave the game.

Offline rfielder

  • Marquis
  • ***
  • Posts: 472
  • Merit: 10
  • Carcassonne Beginner
    • View Profile
    • Cool Country Nights
Re: "Connection Lost" on local game
« Reply #18 on: December 29, 2017, 10:30:54 AM »
Farin - using 4.1.0, received a new error message, please see attached image.  Could not place the tile without the message appearing.  Had to kill the game.

Also - the AI seems to be running slower at times.  I even had one game where the AI froze.  I left it for about 90 minutes, then killed the game.  That was yesterday, different game than the screen capture is from.

Offline ilgabbiano

  • Vagabond
  • *
  • Posts: 1
  • Merit: 0
  • I haven't updated my profile yet!
    • View Profile
Re: "Connection Lost" on local game
« Reply #19 on: January 12, 2018, 04:26:29 AM »
It happened to me too (v. 4.0.2).

I have to save the game, restart jcloister and then reload the game, to continue.

Offline farin

  • Duke
  • *
  • Posts: 233
  • Merit: 41
  • JCloisterZone maintainer
    • View Profile
Re: "Connection Lost" on local game
« Reply #20 on: January 12, 2018, 02:40:46 PM »
Anybody who suffer from connection issues (which may include reported message above)
please try
http://jcloisterzone.com/builds/JCloisterZone-4.1.X.7z

It is just 4.1.0 repacked with old version of Java-Websockers. With exact same version used in JCZ 3.x
Nothing else change. Which should make pretty clear answer if these troubles are cause by networking lib or not.
Because it looks like some messages are lost sometimes. And JCZ network layer was almost unchaged from JCZ 3 to 4, except
lib update to much newer version.

I would be glad for any observation. Thx

Offline Durbs

  • Villein
  • ***
  • Posts: 34
  • Merit: 3
  • Dirty Meeple Trapper
    • View Profile
Re: "Connection Lost" on local game
« Reply #21 on: January 18, 2018, 05:49:59 AM »
Downloaded 4.1.x today and it's fixed all the bugs we were having with 4.1.0: No connection lost, no null pointer exception and no random barn errors.

Only issue they both show is when placed, barns no longer show field control colour - they return to grey.


Offline farin

  • Duke
  • *
  • Posts: 233
  • Merit: 41
  • JCloisterZone maintainer
    • View Profile
Re: "Connection Lost" on local game
« Reply #22 on: January 19, 2018, 12:48:08 PM »
Durbs, bug thanks for confirmation

It really looks that new JavaWebsocket sucks. I am going to use old one (and put it out officially asap)
In long term horizont I will probably migrate to different websocket library, but seems not big issue now.

Offline Durbs

  • Villein
  • ***
  • Posts: 34
  • Merit: 3
  • Dirty Meeple Trapper
    • View Profile
Re: "Connection Lost" on local game
« Reply #23 on: January 23, 2018, 02:24:37 AM »
Great stuff thanks - out of interest, I couldn't see a "Donate" section on your website?


Share via delicious Share via digg Share via facebook Share via furl Share via linkedin Share via myspace Share via reddit Share via stumble Share via technorati Share via twitter

  Subject / Started by Replies / Views Last post
xx
Connection lost in Online game

Started by Hounk

5 Replies
2312 Views
Last post March 01, 2015, 01:00:53 PM
by farin
xx
A copy of "Die Belagerer" for either "Die Katharer" or "Die Kornkreise I"

Started by Hylian87

3 Replies
3683 Views
Last post September 11, 2013, 03:04:52 PM
by Hylian87
xx
RGG "Princess" rule change a case of wrong trsl. or established for "retheming"

Started by Hounk

0 Replies
1441 Views
Last post July 09, 2015, 01:30:40 AM
by Hounk
question
Opinions sought on "base" game and expnasions

Started by jvnoledawg

16 Replies
7394 Views
Last post December 01, 2013, 08:43:15 PM
by whaleyland
question
How to "continue the landscape" in base game

Started by dsegel

6 Replies
2235 Views
Last post February 04, 2017, 06:54:40 AM
by dsegel